CVE-2021-26814

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2021-26814
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-26814.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2021-26814
Aliases
Published
2021-03-06T02:15:12Z
Modified
2024-06-06T13:41:01.118377Z
Severity
  • 8.8 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
[none]
Details

Wazuh API in Wazuh from 4.0.0 to 4.0.3 allows authenticated users to execute arbitrary code with administrative privileges via /manager/files URI. An authenticated user to the service may exploit incomplete input validation on the /manager/files API to inject arbitrary code within the API service script.

References

Affected packages

Git / github.com/wazuh/wazuh

Affected ranges

Type
GIT
Repo
https://github.com/wazuh/wazuh
Events

Affected versions

v4.*

v4.0.0
v4.0.1
v4.0.2
v4.0.3