CVE-2021-32809

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2021-32809
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-32809.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2021-32809
Aliases
Related
Published
2021-08-12T17:15:08Z
Modified
2024-06-06T13:41:28.265595Z
Severity
  • 5.4 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
[none]
Details

ckeditor is an open source WYSIWYG HTML editor with rich content support. A potential vulnerability has been discovered in CKEditor 4 Clipboard package. The vulnerability allowed to abuse paste functionality using malformed HTML, which could result in injecting arbitrary HTML into the editor. It affects all users using the CKEditor 4 plugins listed above at version >= 4.5.2. The problem has been recognized and patched. The fix will be available in version 4.16.2.

References

Affected packages

Git / github.com/ckeditor/ckeditor-releases

Affected ranges

Type
GIT
Repo
https://github.com/ckeditor/ckeditor-releases
Events
Type
GIT
Repo
https://github.com/ckeditor/ckeditor4
Events

Affected versions

4.*

4.10.0
4.10.1
4.11.0
4.11.1
4.11.2
4.11.3
4.11.4
4.12.0
4.12.1
4.13.0
4.13.1
4.14.0
4.14.1
4.15.0
4.15.1
4.16.0
4.16.1
4.5.10
4.5.11
4.5.2
4.5.3
4.5.4
4.5.5
4.5.6
4.5.7
4.5.8
4.5.9
4.6.0
4.6.1
4.6.2
4.7.0
4.7.1
4.7.2
4.7.3
4.8.0
4.9.0
4.9.1
4.9.2

standard/4.*

standard/4.10.0
standard/4.10.1
standard/4.11.0
standard/4.11.1
standard/4.11.2
standard/4.11.3
standard/4.11.4
standard/4.12.0
standard/4.12.1
standard/4.13.0
standard/4.13.1
standard/4.14.0
standard/4.14.1
standard/4.15.0
standard/4.15.1
standard/4.16.0
standard/4.16.1
standard/4.5.10
standard/4.5.11
standard/4.5.2
standard/4.5.3
standard/4.5.4
standard/4.5.5
standard/4.5.6
standard/4.5.7
standard/4.5.8
standard/4.5.9
standard/4.6.0
standard/4.6.1
standard/4.6.2
standard/4.7.0
standard/4.7.1
standard/4.7.2
standard/4.7.3
standard/4.8.0
standard/4.9.0
standard/4.9.1
standard/4.9.2