CVE-2021-34436

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2021-34436
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-34436.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2021-34436
Published
2021-09-02T21:15:07Z
Modified
2024-06-06T13:37:16.990407Z
Severity
  • 9.8 (Critical) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
[none]
Details

In Eclipse Theia 0.1.1 to 0.2.0, it is possible to exploit the default build to obtain remote code execution (and XXE) via the theia-xml-extension. This extension uses lsp4xml (recently renamed to LemMinX) in order to provide language support for XML. This is installed by default.

References

Affected packages

Git / github.com/eclipse-theia/theia

Affected ranges

Type
GIT
Repo
https://github.com/eclipse-theia/theia
Events

Affected versions

v0.*

v0.1.1
v0.2.0