Rapid7 Velociraptor 0.5.9 and prior is vulnerable to a post-authentication persistent cross-site scripting (XSS) issue, where an authenticated user could abuse MIME filetype sniffing to embed executable code on a malicious upload. This issue was fixed in version 0.6.0. Note that login rights to Velociraptor is nearly always reserved for trusted and verified users with IT security backgrounds.
{
"extracted_events": [
{
"cpe": "cpe:2.3:a:rapid7:velociraptor:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "0.6.0"
}
],
"source": "CPE_RANGE"
},
{
"original_tag": "v0.6.0",
"range": [
{
"fixed": "5957468b40238380da1f8e6f2c0ce69a28911aee"
}
],
"source": "REFERENCES_TAG"
}
]
}