A Cross Site Scripting (XSS) vulnerability exists in Codex before 1.4.0 via Notebook/Page name field, which allows malicious users to execute arbitrary code via a crafted http code in a .json file.
{
"extracted_events": [
{
"cpe": "cpe:2.3:a:codexnotes:codex:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.4.0"
}
],
"source": "CPE_RANGE"
},
{
"original_tag": "v1.4.1",
"range": [
{
"fixed": "7f94eafb9647af75ad694eee60335fb8709da6e3"
}
],
"source": "REFERENCES_TAG"
}
]
}