CVE-2022-24712

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2022-24712
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-24712.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2022-24712
Aliases
Published
2022-02-28T16:15:08Z
Modified
2024-06-06T13:58:14.699570Z
Severity
  • 8.8 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS Calculator
Summary
[none]
Details

CodeIgniter4 is the 4.x branch of CodeIgniter, a PHP full-stack web framework. A vulnerability in versions prior to 4.1.9 might allow remote attackers to bypass the CodeIgniter4 Cross-Site Request Forgery (CSRF) protection mechanism. Users should upgrade to version 4.1.9. There are workarounds for this vulnerability, but users will still need to code as these after upgrading to v4.1.9. Otherwise, the CSRF protection may be bypassed. If auto-routing is enabled, check the request method in the controller method before processing. If auto-routing is disabled, either avoid using $routes->add() and instead use HTTP verbs in routes; or check the request method in the controller method before processing.

References

Affected packages

Git / github.com/codeigniter4/codeigniter4

Affected ranges

Type
GIT
Repo
https://github.com/codeigniter4/codeigniter4
Events

Affected versions

4.*

4.0.0
4.0.2

v4.*

v4.0.1
v4.0.3
v4.0.4
v4.0.5
v4.1.0
v4.1.1
v4.1.2
v4.1.3
v4.1.4
v4.1.5
v4.1.6
v4.1.7
v4.1.8