CVE-2022-24737

Source
https://nvd.nist.gov/vuln/detail/CVE-2022-24737
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-24737.json
Aliases
Published
2022-03-07T23:15:07Z
Modified
2023-11-29T09:28:58.330745Z
Details

HTTPie is a command-line HTTP client. HTTPie has the practical concept of sessions, which help users to persistently store some of the state that belongs to the outgoing requests and incoming responses on the disk for further usage. Before 3.1.0, HTTPie didn‘t distinguish between cookies and hosts they belonged. This behavior resulted in the exposure of some cookies when there are redirects originating from the actual host to a third party website. Users are advised to upgrade. There are no known workarounds.

References

Affected packages

Git / github.com/httpie/cli

Affected ranges

Type
GIT
Repo
https://github.com/httpie/cli
Events
Introduced
0The exact introduced commit is unknown
Fixed
Type
GIT
Repo
https://github.com/jakubroztocil/httpie
Events
Introduced
0The exact introduced commit is unknown
Fixed

Affected versions

0.*

0.1.4
0.1.5
0.1.6
0.2.0
0.2.1
0.2.2
0.2.3
0.2.4
0.2.5
0.2.6
0.2.7
0.4.1
0.5.0
0.5.1
0.6.0
0.7.0
0.7.1
0.8.0
0.9.0
0.9.1
0.9.3
0.9.4
0.9.6
0.9.7
0.9.8
0.9.9

1.*

1.0.0
1.0.1
1.0.2
1.0.3

2.*

2.0.0
2.1.0
2.2.0
2.4.0
2.5.0
2.6.0

3.*

3.0.0
3.0.1
3.0.2