A cross-site scripting issue has been discovered in GitLab CE/EE affecting all versions starting from 15.2 before 15.2.5, all versions starting from 15.3 before 15.3.4, all versions starting from 15.4 before 15.4.1 It was possible to exploit a vulnerability in the external status checks feature which could lead to a stored XSS that allowed attackers to perform arbitrary actions on behalf of victims at client side.
{
"cna_assigner": "GitLab",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/2xxx/CVE-2022-2904.json"
}{
"extracted_events": [
{
"cpe": "cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:*",
"range": [
{
"introduced": "15.2"
},
{
"fixed": "15.2.5"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:*",
"range": [
{
"introduced": "15.2"
},
{
"last_affected": "15.2.5"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:*",
"range": [
{
"introduced": "15.3"
},
{
"fixed": "15.3.4"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:*",
"range": [
{
"introduced": "15.3"
},
{
"last_affected": "15.3.4"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:gitlab:gitlab:15.4:*:*:*:community:*:*:*",
"range": [
{
"introduced": "15.4"
},
{
"last_affected": "15.4"
}
],
"source": "CPE_STRING"
},
{
"cpe": "cpe:2.3:a:gitlab:gitlab:15.4:*:*:*:enterprise:*:*:*",
"range": [
{
"introduced": "15.4"
},
{
"last_affected": "15.4"
}
],
"source": "CPE_STRING"
}
]
}