CVE-2022-32172

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2022-32172
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-32172.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2022-32172
Aliases
Published
2022-10-06T18:16:03Z
Modified
2024-06-06T14:01:45.428100Z
Summary
[none]
Details

In Zinc, versions v0.1.9 through v0.3.1 are vulnerable to Stored Cross-Site Scripting when using the delete template functionality. When an authenticated user deletes a template with a XSS payload in the name field, the Javascript payload will be executed and allow an attacker to access the user’s credentials.

References

Affected packages

Git / github.com/zinclabs/zincsearch

Affected ranges

Type
GIT
Repo
https://github.com/zinclabs/zincsearch
Events
Type
GIT
Repo
https://github.com/zincsearch/zincsearch
Events
Introduced
0 Unknown introduced commit / All previous commits are affected
Fixed

Affected versions

v0.*

v0.1.0
v0.1.1
v0.1.2
v0.1.3
v0.1.4
v0.1.5
v0.1.6
v0.1.7
v0.1.8
v0.1.9
v0.2.0
v0.2.1
v0.2.2
v0.2.3
v0.2.4
v0.2.5
v0.2.6
v0.2.7
v0.2.8
v0.2.9
v0.3.0
v0.3.1