CVE-2022-35650

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2022-35650
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-35650.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2022-35650
Aliases
Published
2022-07-25T16:15:08Z
Modified
2024-06-06T14:05:45.772430Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N CVSS Calculator
Summary
[none]
Details

The vulnerability was found in Moodle, occurs due to input validation error when importing lesson questions. This insufficient path checks results in arbitrary file read risk. This vulnerability allows a remote attacker to perform directory traversal attacks. The capability to access this feature is only available to teachers, managers and admins by default.

References

Affected packages

Git / github.com/moodle/moodle

Affected ranges

Type
GIT
Repo
https://github.com/moodle/moodle
Events

Affected versions

v4.*

v4.0.0
v4.0.1