CVE-2022-35975

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2022-35975
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-35975.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2022-35975
Aliases
  • GHSA-873x-829r-gxcp
Published
2022-08-18T18:15:08Z
Modified
2024-05-29T21:34:54Z
Severity
  • 9.8 (Critical) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
[none]
Details

The GitOps Tools Extension for VSCode can make it easier to manage Flux objects. A specially crafted Flux object may allow for remote code execution in the machine running the extension, in the context of the user that is running VSCode. Users using the VSCode extension to manage clusters that are shared amongst other users are affected by this issue. The only safe mitigation is to update to the latest version of the extension.

References

Affected packages

Git / github.com/weaveworks/vscode-gitops-tools

Affected ranges

Type
GIT
Repo
https://github.com/weaveworks/vscode-gitops-tools
Events