Knowage is an open source suite for modern business analytics alternative over big data systems. KnowageLabs / Knowage-Server starting with the 6.x branch and prior to versions 7.4.22, 8.0.9, and 8.1.0 is vulnerable to cross-site scripting because the XSSRequestWrapper::stripXSS method can be bypassed. Versions 7.4.22, 8.0.9, and 8.1.0 contain patches for this issue. There are no known workarounds.
{
"cna_assigner": "GitHub_M",
"cwe_ids": [
"CWE-79",
"CWE-87"
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/39xxx/CVE-2022-39295.json"
}{
"extracted_events": [
{
"cpe": "cpe:2.3:a:eng:knowage:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "6.1.0"
},
{
"fixed": "7.4.22"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:eng:knowage:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "8.0.0"
},
{
"fixed": "8.0.9"
}
],
"source": "CPE_RANGE"
}
]
}