CVE-2023-0871

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2023-0871
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-0871.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2023-0871
Aliases
Published
2023-08-11T17:15:08Z
Modified
2024-06-06T14:12:18.625961Z
Severity
  • 6.1 (Medium) CVSS_V3 - CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N CVSS Calculator
Summary
[none]
Details

XXE injection in /rtc/post/ endpoint in OpenMNS Horizon 31.0.8 and versions earlier than 32.0.2 on multiple platforms is vulnerable to XML external entity (XXE) injection, which can be used for instance to force Horizon to make arbitrary HTTP requests to internal and external services. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Erik Wynter and Moshe Apelbaum for reporting this issue.

References

Affected packages

Git / github.com/opennms/opennms

Affected ranges

Type
GIT
Repo
https://github.com/opennms/opennms
Events

Affected versions

meridian-foundation-2020.*

meridian-foundation-2020.1.37-1
meridian-foundation-2020.1.38-1

meridian-foundation-2021.*

meridian-foundation-2021.1.29-1
meridian-foundation-2021.1.30-1

meridian-foundation-2022.*

meridian-foundation-2022.1.18-1
meridian-foundation-2022.1.19-1

meridian-foundation-2023.*

meridian-foundation-2023.1.5-1
meridian-foundation-2023.1.6-1

opennms-32.*

opennms-32.0.0-1
opennms-32.0.1-1