CVE-2023-26153

Source
https://nvd.nist.gov/vuln/detail/CVE-2023-26153
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-26153.json
Aliases
Published
2023-10-06T05:15:52Z
Modified
2023-11-29T09:53:24.436545Z
Details

Versions of the package geokit-rails before 2.5.0 are vulnerable to Command Injection due to unsafe deserialisation of YAML within the 'geo_location' cookie. This issue can be exploited remotely via a malicious cookie value.

Note:

An attacker can use this vulnerability to execute commands on the host system.

References

Affected packages

Git / github.com/geokit/geokit-rails

Affected ranges

Type
GIT
Repo
https://github.com/geokit/geokit-rails
Events
Introduced
0The exact introduced commit is unknown
Fixed
Fixed

Affected versions

v2.*

v2.0.0
v2.0.1
v2.1.0
v2.2.0
v2.3.0
v2.3.1