CVE-2023-26768

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2023-26768
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-26768.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2023-26768
Related
Published
2023-03-16T15:15:10Z
Modified
2024-06-30T13:19:31.803374Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS Calculator
Summary
[none]
Details

Buffer Overflow vulnerability found in Liblouis v.3.24.0 allows a remote attacker to cause a denial of service via the compileTranslationTable.c and lou_setDataPath functions.

References

Affected packages

Debian:11 / liblouis

Package

Name
liblouis
Purl
pkg:deb/debian/liblouis?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected

Affected versions

3.*

3.16.0-1
3.17.0-1
3.18.0-1
3.18.0-2~bpo10+1
3.18.0-2~bpo11+1
3.18.0-2
3.19.0-1~bpo10+1
3.19.0-1~bpo11+1
3.19.0-1
3.19.0-2
3.20.0-1
3.20.0-2~bpo10+1
3.20.0-2~bpo11+1
3.20.0-2
3.21.0-1~bpo10+1
3.21.0-1~bpo11+1
3.21.0-1
3.22.0-1~bpo10+1
3.22.0-1~bpo11+1
3.22.0-1
3.22.0-2~bpo10+1
3.22.0-2~bpo11+1
3.22.0-2
3.23.0-1~bpo10+1
3.23.0-1~bpo11+1
3.23.0-1
3.24.0-1~bpo11+1
3.24.0-1
3.24.0-2
3.26.0-1~bpo12+1
3.26.0-1
3.27.0-1~bpo12+1
3.27.0-1~bpo12+2
3.27.0-1
3.28.0-1~bpo12+2
3.28.0-1
3.29.0-1~bpo12+2
3.29.0-1

Ecosystem specific

{
    "urgency": "unimportant"
}

Debian:12 / liblouis

Package

Name
liblouis
Purl
pkg:deb/debian/liblouis?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected

Affected versions

3.*

3.24.0-1
3.24.0-2
3.26.0-1~bpo12+1
3.26.0-1
3.27.0-1~bpo12+1
3.27.0-1~bpo12+2
3.27.0-1
3.28.0-1~bpo12+2
3.28.0-1
3.29.0-1~bpo12+2
3.29.0-1

Ecosystem specific

{
    "urgency": "unimportant"
}

Debian:13 / liblouis

Package

Name
liblouis
Purl
pkg:deb/debian/liblouis?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.24.0-2

Affected versions

3.*

3.24.0-1

Ecosystem specific

{
    "urgency": "unimportant"
}