CVE-2023-27599

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2023-27599
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-27599.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2023-27599
Aliases
  • GHSA-qvj2-vqrg-f5jx
Published
2023-03-15T21:15:09Z
Modified
2024-05-30T04:02:30.480566Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS Calculator
Summary
[none]
Details

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.7 and 3.2.4, when the function append_hf handles a SIP message with a malformed To header, a call to the function abort() is performed, resulting in a crash. This is due to the following check in data_lump.c:399 in the function anchor_lump. An attacker abusing this vulnerability will crash OpenSIPS leading to Denial of Service. It affects configurations containing functions that make use of the affected code, such as the function append_hf. This issue has been fixed in versions 3.1.7 and 3.2.4.

References

Affected packages

Git / github.com/opensips/opensips

Affected ranges

Type
GIT
Repo
https://github.com/opensips/opensips
Events
Introduced
0 Unknown introduced commit / All previous commits are affected
Fixed

Affected versions

1.*

1.11.0

2.*

2.1-alpha1
2.1-alpha2
2.1-alpha3
2.1-rc1