CVE-2023-27600

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2023-27600
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-27600.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2023-27600
Aliases
  • GHSA-67w7-g4j8-3wcx
Published
2023-03-15T22:15:10Z
Modified
2024-05-30T04:02:32.747487Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS Calculator
Summary
[none]
Details

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.7 and 3.2.4, OpenSIPS crashes when a malformed SDP body is received and is processed by the delete_sdp_line function in the sipmsgops module. This issue can be reproduced by calling the function with an SDP body that does not terminate by a line feed (i.e. \n).

The vulnerability was found while performing black-box fuzzing against an OpenSIPS server running a configuration that made use of the functions codec_delete_except_re and codec_delete_re. The same issue was also discovered while performing coverage guided fuzzing on the function codec_delete_except_re. The crash happens because the function delete_sdp_line expects that an SDP line is terminated by a line feed (\n).

By abusing this vulnerability, an attacker is able to crash the server. It affects configurations containing functions that rely on the affected code, such as the function codec_delete_except_re. Due to the sanity check that is performed in the del_lump function, exploitation of this issue will generate an abort in the lumps processing function, resulting in a Denial of Service. This issue is patched in versions 3.1.7 and 3.2.4.

References

Affected packages

Git / github.com/opensips/opensips

Affected ranges

Type
GIT
Repo
https://github.com/opensips/opensips
Events
Introduced
0 Unknown introduced commit / All previous commits are affected
Fixed

Affected versions

1.*

1.11.0

2.*

2.1-alpha1
2.1-alpha2
2.1-alpha3
2.1-rc1