CVE-2023-28098

Source
https://cve.org/CVERecord?id=CVE-2023-28098
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-28098.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2023-28098
Aliases
  • GHSA-jrqg-vppj-hr2h
Downstream
Published
2023-03-15T22:11:01Z
Modified
2026-10-28T02:50:24Z
Severity
  • 5.9 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS Calculator
Summary
OpenSIPS has vulnerability in the Digest Authentication Parser
Details

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.7 and 3.2.4, a specially crafted Authorization header causes OpenSIPS to crash or behave in an unexpected way due to a bug in the function parse_param_name() . This issue was discovered while performing coverage guided fuzzing of the function parse_msg. The AddressSanitizer identified that the issue occurred in the function q_memchr() which is being called by the function parse_param_name(). This issue may cause erratic program behaviour or a server crash. It affects configurations containing functions that make use of the affected code, such as the function www_authorize() . Versions 3.1.7 and 3.2.4 contain a fix.

Database specific
{
    "cna_assigner":  "GitHub_M",
    "cwe_ids":  [
        "CWE-20"
    ],
    "osv_generated_from":  "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/28xxx/CVE-2023-28098.json"
}
References

Affected packages

Git / github.com/opensips/opensips

Affected ranges

Type
GIT
Repo
https://github.com/opensips/opensips
Events
Database specific
Show details
{
    "extracted_events":  [
        {
            "cpe":  "cpe:2.3:a:opensips:opensips:*:*:*:*:*:*:*:*",
            "range":  [
                {
                    "introduced":  "0"
                },
                {
                    "fixed":  "3.1.7"
                }
            ],
            "source":  "CPE_RANGE"
        },
        {
            "cpe":  "cpe:2.3:a:opensips:opensips:*:*:*:*:*:*:*:*",
            "range":  [
                {
                    "introduced":  "3.2.0"
                },
                {
                    "fixed":  "3.2.4"
                }
            ],
            "source":  "CPE_RANGE"
        },
        {
            "range":  [
                {
                    "fixed":  "dd9141b6f67d7df4072f3430f628d4b73df5e102"
                }
            ],
            "source":  "REFERENCES_COMMIT"
        }
    ]
}

Affected versions

1.*
1.11.0
2.*
2.1-alpha1
2.1-alpha2
2.1-alpha3
2.1-rc1
3.*
3.1.0
3.1.0-beta
3.1.1
3.1.2
3.1.3
3.1.4
3.1.5
3.1.6
3.2.0
3.2.1
3.2.2
3.2.3

Database specific

source
"https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-28098.json"