CVE-2023-28109

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2023-28109
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-28109.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2023-28109
Aliases
Published
2023-03-16T17:15:09Z
Modified
2024-05-23T01:26:40.923948Z
Severity
  • 6.5 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N CVSS Calculator
Summary
[none]
Details

Play With Docker is a browser-based Docker playground. Versions 0.0.2 and prior are vulnerable to domain hijacking. Because CORS configuration was not correct, an attacker could use play-with-docker.com as an example and set the origin header in an http request as evil-play-with-docker.com. The domain would echo in response header, which successfully bypassed the CORS policy and retrieved basic user information. This issue has been fixed in commit ed82247c9ab7990ad76ec2bf1498c2b2830b6f1a. There are no known workarounds.

References

Affected packages

Git / github.com/play-with-docker/play-with-docker

Affected ranges

Type
GIT
Repo
https://github.com/play-with-docker/play-with-docker
Events
Introduced
0 Unknown introduced commit / All previous commits are affected
Fixed

Affected versions

v0.*

v0.0.1
v0.0.2