CVE-2023-30541

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2023-30541
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-30541.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2023-30541
Aliases
Published
2023-04-17T22:15:10Z
Modified
2024-06-06T14:21:19.567770Z
Severity
  • 5.3 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L CVSS Calculator
Summary
[none]
Details

OpenZeppelin Contracts is a library for secure smart contract development. A function in the implementation contract may be inaccessible if its selector clashes with one of the proxy's own selectors. Specifically, if the clashing function has a different signature with incompatible ABI encoding, the proxy could revert while attempting to decode the arguments from calldata. The probability of an accidental clash is negligible, but one could be caused deliberately and could cause a reduction in availability. The issue has been fixed in version 4.8.3. As a workaround if a function appears to be inaccessible for this reason, it may be possible to craft the calldata such that ABI decoding does not fail at the proxy and the function is properly proxied through.

References

Affected packages

Git / github.com/openzeppelin/openzeppelin-contracts

Affected ranges

Type
GIT
Repo
https://github.com/openzeppelin/openzeppelin-contracts
Events
Type
GIT
Repo
https://github.com/openzeppelin/openzeppelin-contracts-upgradeable
Events

Affected versions

v3.*

v3.1.0-solc-0.7
v3.2.0
v3.2.1-solc-0.7
v3.2.2-solc-0.7
v3.3.0
v3.3.0-rc.0
v3.3.0-rc.1
v3.3.0-rc.2
v3.4.0
v3.4.0-rc.0

v4.*

v4.0.0
v4.0.0-beta.0
v4.0.0-beta.1
v4.0.0-rc.0
v4.1.0
v4.1.0-rc.0
v4.2.0
v4.2.0-rc.0
v4.3.0
v4.3.0-rc.0
v4.3.1
v4.3.2
v4.4.0
v4.4.0-rc.0
v4.4.0-rc.1
v4.4.1
v4.8.0
v4.8.0-rc.0
v4.8.0-rc.1
v4.8.0-rc.2
v4.8.1
v4.8.2