CVE-2023-31134

Source
https://nvd.nist.gov/vuln/detail/CVE-2023-31134
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-31134.json
Aliases
Published
2023-05-09T14:15:13Z
Modified
2024-05-14T12:54:11.268011Z
Summary
[none]
Details

Tauri is software for building applications for multi-platform deployment. The Tauri IPC is usually strictly isolated from external websites, but in versions 1.0.0 until 1.0.9, 1.1.0 until 1.1.4, and 1.2.0 until 1.2.5, the isolation can be bypassed by redirecting an existing Tauri window to an external website. This is either possible by an application implementing a feature for users to visit arbitrary websites or due to a bug allowing the open redirect. This allows the external website access to the IPC layer and therefore to all configured and exposed Tauri API endpoints and application specific implemented Tauri commands. This issue has been patched in versions 1.0.9, 1.1.4, and 1.2.5. As a workaround, prevent arbitrary input in redirect features and/or only allow trusted websites access to the IPC.

References

Affected packages

Git / github.com/tauri-apps/tauri

Affected ranges

Affected versions

api-v1.*

api-v1.0
api-v1.0.0
api-v1.0.1
api-v1.0.2

cli.*

cli.js-v1.0.0
cli.js-v1.0.1
cli.js-v1.0.2
cli.js-v1.0.3
cli.js-v1.0.4
cli.js-v1.0.5
cli.rs-v1.0
cli.rs-v1.0.0
cli.rs-v1.0.1
cli.rs-v1.0.2
cli.rs-v1.0.3
cli.rs-v1.0.4
cli.rs-v1.0.5

tauri-build-v1.*

tauri-build-v1.0
tauri-build-v1.0.0
tauri-build-v1.0.1
tauri-build-v1.0.2
tauri-build-v1.0.3
tauri-build-v1.0.4

tauri-bundler-v1.*

tauri-bundler-v1.0.0
tauri-bundler-v1.0.1
tauri-bundler-v1.0.2
tauri-bundler-v1.0.3
tauri-bundler-v1.0.4
tauri-bundler-v1.0.5

tauri-codegen-v1.*

tauri-codegen-v1.0
tauri-codegen-v1.0.0
tauri-codegen-v1.0.1
tauri-codegen-v1.0.2
tauri-codegen-v1.0.3
tauri-codegen-v1.0.4

tauri-macros-v1.*

tauri-macros-v1.0
tauri-macros-v1.0.0
tauri-macros-v1.0.1
tauri-macros-v1.0.2
tauri-macros-v1.0.3
tauri-macros-v1.0.4

tauri-runtime-v0.*

tauri-runtime-v0.10.0
tauri-runtime-v0.10.1
tauri-runtime-v0.10.2
tauri-runtime-v0.9
tauri-runtime-v0.9.0

tauri-runtime-wry-v0.*

tauri-runtime-wry-v0.10.0
tauri-runtime-wry-v0.10.1
tauri-runtime-wry-v0.10.2
tauri-runtime-wry-v0.9
tauri-runtime-wry-v0.9.0

tauri-utils-v1.*

tauri-utils-v1.0
tauri-utils-v1.0.0
tauri-utils-v1.0.1
tauri-utils-v1.0.2
tauri-utils-v1.0.3

tauri-v1.*

tauri-v1.0.0
tauri-v1.0.1
tauri-v1.0.2
tauri-v1.0.3
tauri-v1.0.4
tauri-v1.0.5
tauri-v1.0.6

v1.*

v1.0.0
v1.0.1
v1.0.2
v1.0.3
v1.0.4
v1.0.5