CVE-2023-32699

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2023-32699
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-32699.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2023-32699
Aliases
  • GHSA-qffq-8gf8-mhq7
Published
2023-05-30T19:15:10Z
Modified
2024-05-23T01:28:51.196726Z
Severity
  • 6.5 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H CVSS Calculator
Summary
[none]
Details

MeterSphere is an open source continuous testing platform. Version 2.9.1 and prior are vulnerable to denial of service. ‚ÄčThe checkUserPassword method is used to check whether the password provided by the user matches the password saved in the database, and the CodingUtil.md5 method is used to encrypt the original password with MD5 to ensure that the password will not be saved in plain text when it is stored. If a user submits a very long password when logging in, the system will be forced to execute the long password MD5 encryption process, causing the server CPU and memory to be exhausted, thereby causing a denial of service attack on the server. This issue is fixed in version 2.10.0-lts with a maximum password length.

References

Affected packages

Git / github.com/metersphere/metersphere

Affected ranges

Type
GIT
Repo
https://github.com/metersphere/metersphere
Events
Introduced
0 Unknown introduced commit / All previous commits are affected
Fixed

Affected versions

v1.*

v1.0.0
v1.0.1
v1.0.2
v1.0.3
v1.1.0
v1.1.1
v1.1.2
v1.2.0
v1.2.1
v1.3.0
v1.3.1
v1.4.0
v1.4.1
v1.4.2
v1.4.3
v1.5.0
v1.5.1
v1.6.0
v1.6.1
v1.6.2
v1.7.0
v1.7.1
v1.7.2
v1.7.3
v1.8.0
v1.8.1
v1.8.2