CVE-2023-34442

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2023-34442
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-34442.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2023-34442
Aliases
Published
2023-07-10T16:15:52Z
Modified
2024-06-06T14:24:09.760351Z
Severity
  • 3.3 (Low) CVSS_V3 - CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N CVSS Calculator
Summary
[none]
Details

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Software Foundation Apache Camel.This issue affects Apache Camel: from 3.X through <=3.14.8, from 3.18.X through <=3.18.7, from 3.20.X through <= 3.20.5, from 4.X through <= 4.0.0-M3.

Users should upgrade to 3.14.9, 3.18.8, 3.20.6 or 3.21.0 and for users on Camel 4.x update to 4.0.0-M1

References

Affected packages

Git / github.com/apache/camel

Affected ranges

Type
GIT
Repo
https://github.com/apache/camel
Events

Affected versions

camel-3.*

camel-3.0.0
camel-3.14.0
camel-3.14.1
camel-3.14.2
camel-3.14.3
camel-3.14.4
camel-3.14.5
camel-3.14.6
camel-3.14.7
camel-3.14.8