CVE-2023-37582

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2023-37582
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-37582.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2023-37582
Aliases
Published
2023-07-12T10:15:11Z
Modified
2024-06-13T07:33:06.907145Z
Severity
  • 9.8 (Critical) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
[none]
Details

The RocketMQ NameServer component still has a remote command execution vulnerability as the CVE-2023-33246 issue was not completely fixed in version 5.1.1.

When NameServer address are leaked on the extranet and lack permission verification, an attacker can exploit this vulnerability by using the update configuration function on the NameServer component to execute commands as the system users that RocketMQ is running as.

It is recommended for users to upgrade their NameServer version to 5.1.2 or above for RocketMQ 5.x or 4.9.7 or above for RocketMQ 4.x to prevent these attacks.

References

Affected packages

Git / github.com/apache/rocketmq

Affected ranges

Type
GIT
Repo
https://github.com/apache/rocketmq
Events

Affected versions

rocketmq-all-5.*

rocketmq-all-5.0.0
rocketmq-all-5.1.0
rocketmq-all-5.1.1