CVE-2023-38704

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2023-38704
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-38704.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2023-38704
Aliases
Published
2023-08-07T20:15:09Z
Modified
2024-06-29T02:15:25.930148Z
Severity
  • 9.8 (Critical) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
[none]
Details

import-in-the-middle is a module loading interceptor specifically for ESM modules. The import-in-the-middle loader works by generating a wrapper module on the fly. The wrapper uses the module specifier to load the original module and add some wrapping code. Prior to version 1.4.2, it allows for remote code execution in cases where an application passes user-supplied input directly to the import() function. This vulnerability has been patched in import-in-the-middle version 1.4.2.

Some workarounds are available. Do not pass any user-supplied input to import(). Instead, verify it against a set of allowed values. If using import-in-the-middle, directly or indirectly, and support for EcmaScript Modules is not needed, ensure that no options are set, either via command-line or the NODE_OPTIONS environment variable, that would enable loader hooks.

References

Affected packages

Git / github.com/datadog/import-in-the-middle

Affected ranges

Type
GIT
Repo
https://github.com/datadog/import-in-the-middle
Events
Introduced
0 Unknown introduced commit / All previous commits are affected
Fixed
Type
GIT
Repo
https://github.com/nodejs/import-in-the-middle
Events
Introduced
0 Unknown introduced commit / All previous commits are affected
Fixed

Affected versions

v1.*

v1.0.0
v1.0.1
v1.1.0
v1.1.1
v1.1.2
v1.2.1
v1.2.2
v1.2.3
v1.3.0
v1.3.1
v1.3.2
v1.3.3
v1.3.4
v1.3.5
v1.4.0
v1.4.1