A reflected cross-site scripting (XSS) vulnerability in the component /ui/diagnostics/log/core/ of OPNsense Community Edition before 23.7 and Business Edition before 23.4.2 allows attackers to inject arbitrary JavaScript via the URL path.
{
"cna_assigner": "mitre",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/39xxx/CVE-2023-39000.json",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"fixed": "23.4.2"
}
],
"source": "DESCRIPTION"
}
]
}
]
}{
"extracted_events": [
{
"cpe": "cpe:2.3:a:opnsense:opnsense:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "23.7"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "d1f350ce70e477adc86d445f5cda9b24f9ff0168"
}
],
"source": "REFERENCES_COMMIT"
}
]
}