CVE-2023-41890

Source
https://nvd.nist.gov/vuln/detail/CVE-2023-41890
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-41890.json
Aliases
Published
2023-09-19T15:15:52Z
Modified
2023-12-19T17:04:03.967941Z
Details

Sustainsys.Saml2 library adds SAML2P support to ASP.NET web sites, allowing the web site to act as a SAML2 Service Provider. Prior to versions 1.0.3 and 2.9.2, when a response is processed, the issuer of the Identity Provider is not sufficiently validated. This could allow a malicious identity provider to craft a Saml2 response that is processed as if issued by another identity provider. It is also possible for a malicious end user to cause stored state intended for one identity provider to be used when processing the response from another provider. An application is impacted if they rely on any of these features in their authentication/authorization logic: the issuer of the generated identity and claims; or items in the stored request state (AuthenticationProperties). This issue is patched in versions 2.9.2 and 1.0.3. The AcsCommandResultCreated notification can be used to add the validation required if an upgrade to patched packages is not possible.

References

Affected packages

Git / github.com/simplesamlphp/saml2

Affected ranges

Type
GIT
Repo
https://github.com/simplesamlphp/saml2
Events
Type
GIT
Repo
https://github.com/sustainsys/saml2
Events

Affected versions

4.*

4.6.9

v2.*

v2.0.0
v2.0.1
v2.1
v2.2
v2.3
v2.3.1
v2.3.2
v2.3.3
v2.3.4
v2.3.5
v2.3.6
v2.3.7
v2.3.8
v2.3.9

v3.*

v3.0.0
v3.0.1
v3.0.2
v3.0.3
v3.1.0
v3.1.1
v3.1.2
v3.1.3
v3.1.4
v3.1.5
v3.1.6
v3.2
v3.2.1
v3.2.2
v3.2.3
v3.2.4
v3.2.5
v3.2.6
v3.3.0
v3.3.10
v3.3.11
v3.3.2
v3.3.3
v3.3.4
v3.3.5
v3.3.6
v3.3.7
v3.3.8
v3.4.0
v3.4.1
v3.4.2
v3.4.3
v3.4.4
v3.4.5

v4.*

v4.0.0
v4.0.1
v4.0.2
v4.0.3
v4.1.0
v4.1.1
v4.1.10
v4.1.11
v4.1.12
v4.1.2
v4.1.3
v4.1.4
v4.1.5
v4.1.6
v4.1.7
v4.1.8
v4.1.9
v4.2.0
v4.2.1
v4.2.2
v4.2.3
v4.2.4
v4.2.5
v4.2.6
v4.2.7
v4.2.8
v4.3.0
v4.3.1
v4.4.0
v4.4.1
v4.5.0
v4.5.1
v4.6.0
v4.6.1
v4.6.10
v4.6.2
v4.6.3
v4.6.4
v4.6.5
v4.6.6
v4.6.7
v4.6.8

v5.*

v5.0.0-alpha.1
v5.0.0-alpha.10
v5.0.0-alpha.11
v5.0.0-alpha.12
v5.0.0-alpha.13
v5.0.0-alpha.2
v5.0.0-alpha.4
v5.0.0-alpha.6
v5.0.0-alpha.7
v5.0.0-alpha.8
v5.0.0-alpha.9