CVE-2023-43795

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2023-43795
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-43795.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2023-43795
Aliases
Published
2023-10-25T18:17:32Z
Modified
2024-05-29T20:52:01Z
Severity
  • 9.8 (Critical) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
[none]
Details

GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. The OGC Web Processing Service (WPS) specification is designed to process information from any server using GET and POST requests. This presents the opportunity for Server Side Request Forgery. This vulnerability has been patched in version 2.22.5 and 2.23.2.

References

Affected packages

Git / github.com/geoserver/geoserver

Affected ranges

Type
GIT
Repo
https://github.com/geoserver/geoserver
Events
Introduced
0 Unknown introduced commit / All previous commits are affected
Fixed