CVE-2023-45684

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2023-45684
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-45684.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2023-45684
Published
2023-11-14T15:15:07Z
Modified
2024-05-30T04:11:20.287015Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N CVSS Calculator
Summary
[none]
Details

Northern.tech CFEngine Enterprise before 3.21.3 allows SQL Injection. The fixed versions are 3.18.6 and 3.21.3. The earliest affected version is 3.6.0. The issue is in the Mission Portal login page in the CFEngine hub.

References

Affected packages

Git / github.com/cfengine/core

Affected ranges

Type
GIT
Repo
https://github.com/cfengine/core
Events
Introduced
0 Unknown introduced commit / All previous commits are affected
Fixed

Affected versions

3.*

3.10.0b1-build1
3.12.0a1-build1
3.12.0b1
3.12.0b1-build1
3.12.0b1-build2
3.13.0
3.13.0-build1
3.13.0-build2
3.14.0
3.14.0-2
3.14.0-2-build1
3.14.0-build1
3.14.0-build2
3.14.0-build3
3.14.0-build4
3.15.0-build1
3.15.0-build2
3.15.0b1
3.15.0b1-build1
3.15.0b1-build2
3.15.0b1-build3
3.15.0b1-build4
3.16.0
3.16.0-build1
3.17.0
3.17.0-build1
3.18.0
3.18.0-1-build1
3.18.0-1-build2
3.18.0-1-build3
3.18.0-2
3.18.0-2-build1
3.18.0-2-build2
3.18.0-build1
3.18.0-build2
3.18.0-build3
3.18.1
3.18.1-build1
3.18.1-build2
3.18.1-build3
3.18.1-build4
3.18.1-build5
3.18.2
3.18.2-build1
3.18.2-build2
3.18.2-build3
3.18.2-build4
3.18.2-build5
3.18.3
3.18.3-2
3.18.3-2-build1
3.18.3-2-build2
3.18.3-2-build3
3.18.3-build1
3.18.3-build2
3.18.3-build3
3.18.3-build4
3.18.3-build5
3.18.3-build6
3.18.4
3.18.4-build1
3.18.4-build2
3.18.5
3.18.5-build1
3.18.5-build2
3.18.5-build3
3.18.5-build4
3.18.5-build5
3.18.6-build1
3.18.6-build2
3.3.x-branchpoint
3.4.0a1
3.4.x-branchpoint
3.5.0a1
3.5.0a2
3.5.0b1
3.5.x-branchpoint
3.6.0b1
3.6.0b1-build1
3.6.0b1-build2
3.6.0b1-build3
3.6.0b1-build4
3.6.0b2
3.6.0b2-build1
3.6.0b2-build2
3.6.0b2-build3
3.6.0b2-build4
3.6.0b2-build5
3.6.0eb1-build1
3.6.0eb1-build2
3.6.0eb2-build1
3.6.0eb2-build2
3.6.x-branchpoint
3.6rc
3.6rc-build1
3.6rc-build2
3.8.0b1-build1
3.8.0b1-build2
3.9.0b1-build1
3.9.0b1-build2

Other

svn-migration-point

v3.*

v3.6.0a0