CVE-2023-46248

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2023-46248
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-46248.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2023-46248
Aliases
  • GHSA-8wmq-fwv7-xmwq
Published
2023-10-31T16:15:09Z
Modified
2024-06-06T14:25:21.044213Z
Severity
  • 8.8 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
[none]
Details

Cody is an artificial intelligence (AI) coding assistant. The Cody AI VSCode extension versions 0.10.0 through 0.14.0 are vulnerable to Remote Code Execution under certain conditions. An attacker in control of a malicious repository could modify the Cody configuration file .vscode/cody.json and overwrite Cody commands. If a user with the extension installed opens this malicious repository and runs a Cody command such as /explain or /doc, this could allow arbitrary code execution on the user's machine. The vulnerability is rated as critical severity, but with low exploitability. It requires the user to have a malicious repository loaded and execute the overwritten command in VS Code. The issue is exploitable regardless of the user blocking code execution on a repository through VS Code Workspace Trust. The issue was found during a regular 3rd party penetration test. The maintainers of Cody do not have evidence of open source repositories having malicious .vscode/cody.json files to exploit this vulnerability. The issue is fixed in version 0.14.1 of the Cody VSCode extension. In case users can't promptly upgrade, they should not open any untrusted repositories with the Cody extension loaded.

References

Affected packages

Git / github.com/sourcegraph/cody

Affected ranges

Type
GIT
Repo
https://github.com/sourcegraph/cody
Events

Affected versions

vscode-v0.*

vscode-v0.10.0
vscode-v0.12.0
vscode-v0.12.4
vscode-v0.14.0