CVE-2023-48056

Source
https://nvd.nist.gov/vuln/detail/CVE-2023-48056
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-48056.json
Aliases
Published
2023-11-16T18:15:07Z
Modified
2023-12-02T21:06:14.683089Z
Details

PyPinkSign v0.5.1 uses a non-random or static IV for Cipher Block Chaining (CBC) mode in AES encryption. This vulnerability can lead to the disclosure of information and communications.

References

Affected packages

Git / github.com/bandoche/pypinksign

Affected ranges

Type
GIT
Repo
https://github.com/bandoche/pypinksign
Events
Introduced
0The exact introduced commit is unknown
Last affected

Affected versions

0.*

0.2
0.2.1
0.2.2

v0.*

v0.3
v0.4
v0.4.2
v0.4.3
v0.4.4
v0.4.5
v0.5.0
v0.5.1