CVE-2023-48217

Source
https://nvd.nist.gov/vuln/detail/CVE-2023-48217
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-48217.json
Aliases
Published
2023-11-14T22:15:31Z
Modified
2023-11-29T10:20:44.167665Z
Details

Statamic is a flat-first, Laravel + Git powered CMS designed for building websites. In affected versions certain additional PHP files crafted to look like images may be uploaded regardless of mime type validation rules. This affects front-end forms using the "Forms" feature, and asset upload fields in the control panel. Malicious users could leverage this vulnerability to upload and execute code. This issue has been patched in versions 3.4.14 and 4.34.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.

References

Affected packages

Git / github.com/statamic/cms

Affected ranges

Type
GIT
Repo
https://github.com/statamic/cms
Events

Affected versions

v4.*

v4.0.0
v4.1.0
v4.1.1
v4.1.2
v4.1.3
v4.10.0
v4.10.1
v4.10.2
v4.11.0
v4.12.0
v4.13.0
v4.13.1
v4.13.2
v4.14.0
v4.15.0
v4.16.0
v4.17.0
v4.18.0
v4.19.0
v4.2.0
v4.20.0
v4.21.0
v4.22.0
v4.23.0
v4.23.1
v4.23.2
v4.24.0
v4.25.0
v4.26.0
v4.26.1
v4.27.0
v4.28.0
v4.29.0
v4.3.0
v4.30.0
v4.31.0
v4.32.0
v4.33.0
v4.4.0
v4.5.0
v4.6.0
v4.7.0
v4.8.0
v4.9.0
v4.9.1
v4.9.2