Rapid7 Velociraptor versions prior to 0.7.0-4 suffer from a reflected cross site scripting vulnerability. This vulnerability allows attackers to inject JS into the error path, potentially leading to unauthorized execution of scripts within a user's web browser. This vulnerability is fixed in version 0.7.0-04 and a patch is available to download. Patches are also available for version 0.6.9 (0.6.9-1).
{
"cna_assigner": "rapid7",
"cwe_ids": [
"CWE-79"
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/5xxx/CVE-2023-5950.json",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"fixed": "0.7.0-4"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
},
{
"extracted_events": [
{
"range": [
{
"fixed": "0.7.0-4"
}
],
"source": "DESCRIPTION"
}
]
}
]
}{
"extracted_events": [
{
"cpe": "cpe:2.3:a:rapid7:velociraptor:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "0.6.9-1"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:rapid7:velociraptor:0.7.0:-:*:*:*:*:*:*",
"range": [
{
"introduced": "0.7.0-NA"
},
{
"last_affected": "0.7.0-NA"
}
],
"source": "CPE_STRING"
},
{
"cpe": "cpe:2.3:a:rapid7:velociraptor:0.7.0:rc1:*:*:*:*:*:*",
"range": [
{
"introduced": "0.7.0-rc1"
},
{
"last_affected": "0.7.0-rc1"
}
],
"source": "CPE_STRING"
},
{
"cpe": "cpe:2.3:a:rapid7:velociraptor:0.7.0-3:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0.7.0-3"
},
{
"last_affected": "0.7.0-3"
}
],
"source": "CPE_STRING"
},
{
"original_tag": "v0.7.0",
"range": [
{
"fixed": "0ef0e8bd3d8ce596e8efaebde32cfcd740aee6c1"
}
],
"source": "REFERENCES_TAG"
}
]
}