CVE-2023-5954

Source
https://nvd.nist.gov/vuln/detail/CVE-2023-5954
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-5954.json
Aliases
Published
2023-11-09T21:15:25Z
Modified
2023-12-27T17:06:11.209831Z
Details

HashiCorp Vault and Vault Enterprise inbound client requests triggering a policy check can lead to an unbounded consumption of memory. A large number of these requests may lead to denial-of-service. Fixed in Vault 1.15.2, 1.14.6, and 1.13.10.

References

Affected packages

Git / github.com/hashicorp/vault

Affected ranges

Affected versions

sdk/v0.*

sdk/v0.10.2

v1.*

v1.15.0
v1.15.1