CVE-2024-23807

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2024-23807
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-23807.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2024-23807
Published
2024-02-29T01:44:10Z
Modified
2024-05-29T20:13:28Z
Summary
[none]
Details

The Apache Xerces C++ XML parser on versions 3.0.0 before 3.2.5 contains a use-after-free error triggered during the scanning of external DTDs.

Users are recommended to upgrade to version 3.2.5 which fixes the issue, or mitigate the issue by disabling DTD processing. This can be accomplished via the DOM using a standard parser feature, or via SAX using the XERCESDISABLEDTD environment variable.

This issue has been disclosed before as CVE-2018-1311, but unfortunately that advisory incorrectly stated the issue would be fixed in version 3.2.3 or 3.2.4.

References

Affected packages

Git / github.com/apache/xerces-c

Affected ranges

Type
GIT
Repo
https://github.com/apache/xerces-c
Events