CVE-2024-27354

Source
https://nvd.nist.gov/vuln/detail/CVE-2024-27354
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-27354.json
Aliases
Related
Published
2024-03-01T23:15:08Z
Modified
2024-03-21T21:20:08.476185Z
Details

An issue was discovered in phpseclib 1.x before 1.0.23, 2.x before 2.0.47, and 3.x before 3.0.36. An attacker can construct a malformed certificate containing an extremely large prime to cause a denial of service (CPU consumption for an isPrime primality check). NOTE: this issue was introduced when attempting to fix CVE-2023-27560.

References

Affected packages

Git / github.com/phpseclib/phpseclib

Affected ranges

Type
GIT
Repo
https://github.com/phpseclib/phpseclib
Events
Introduced
0The exact introduced commit is unknown
Fixed

Affected versions

0.*

0.1.0
0.1.1
0.1.2
0.1.5
0.2.0
0.2.1
0.2.2
0.3.0
0.3.1
0.3.10
0.3.5
0.3.6
0.3.7
0.3.8
0.3.9

1.*

1.0.1
1.0.10
1.0.11
1.0.12
1.0.13
1.0.14
1.0.15
1.0.16
1.0.17
1.0.18
1.0.19
1.0.2
1.0.20
1.0.21
1.0.22
1.0.3
1.0.4
1.0.5
1.0.6
1.0.7
1.0.8
1.0.9