CVE-2024-27906

Source
https://nvd.nist.gov/vuln/detail/CVE-2024-27906
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-27906.json
Aliases
Published
2024-02-29T11:15:08Z
Modified
2024-04-01T07:26:47.009131Z
Details

Apache Airflow, versions before 2.8.2, has a vulnerability that allows authenticated users to view DAG code and import errors of DAGs they do not have permission to view through the API and the UI.

Users of Apache Airflow are recommended to upgrade to version 2.8.2 or newer to mitigate the risk associated with this vulnerability

References

Affected packages

Git / github.com/apache/airflow

Affected ranges

Type
GIT
Repo
https://github.com/apache/airflow
Events
Introduced
0The exact introduced commit is unknown
Fixed

Affected versions

Other

constraints-2-3
constraints-latest

constraints-2.*

constraints-2.0.0rc1
constraints-2.0.0rc2
constraints-2.0.0rc3
constraints-2.0.1rc1
constraints-2.1.0rc1
constraints-2.2.0b1
constraints-2.2.0b2
constraints-2.2.0rc1
constraints-2.3.0b1
constraints-2.3.0rc1
constraints-2.3.0rc2
constraints-2.4.0b1
constraints-2.8.0
constraints-2.8.0b1
constraints-2.8.0rc1
constraints-2.8.0rc2
constraints-2.8.0rc3
constraints-2.8.0rc4
constraints-2.8.1rc1
constraints-2.8.2rc1
constraints-2.8.2rc2
constraints-2.8.2rc3