CVE-2024-29511

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2024-29511
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-29511.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2024-29511
Related
Published
2024-07-03T19:15:03Z
Modified
2024-07-08T18:26:25.401291Z
Summary
[none]
Details

Artifex Ghostscript before 10.03.1, when Tesseract is used for OCR, has a directory traversal issue that allows arbitrary file reading (and writing of error messages to arbitrary files) via OCRLanguage. For example, exploitation can use debugfile /tmp/out and userpatterns_file /etc/passwd.

References

Affected packages

Debian:11 / ghostscript

Package

Name
ghostscript
Purl
pkg:deb/debian/ghostscript?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected

Affected versions

9.*

9.53.3~dfsg-7
9.53.3~dfsg-7+deb11u1
9.53.3~dfsg-7+deb11u2
9.53.3~dfsg-7+deb11u3
9.53.3~dfsg-7+deb11u4
9.53.3~dfsg-7+deb11u5
9.53.3~dfsg-7+deb11u6
9.53.3~dfsg-7+deb11u7
9.53.3~dfsg-8
9.54.0~dfsg-1
9.54.0~dfsg-2
9.54.0~dfsg-3
9.54.0~dfsg-4
9.54.0~dfsg-5
9.55.0~~rc1~dfsg-1
9.55.0~dfsg-1
9.55.0~dfsg-2
9.55.0~dfsg-3
9.56.0~~rc1~dfsg-1
9.56.0~~rc2~dfsg-1
9.56.0~dfsg-1
9.56.1~dfsg-1

10.*

10.0.0~dfsg-1
10.0.0~dfsg-2
10.0.0~dfsg-3
10.0.0~dfsg-4
10.0.0~dfsg-5
10.0.0~dfsg-6
10.0.0~dfsg-7
10.0.0~dfsg-8
10.0.0~dfsg-9
10.0.0~dfsg-10
10.0.0~dfsg-11
10.01.2~dfsg-1
10.02.0~dfsg-1
10.02.0~dfsg-2
10.02.1~dfsg-1
10.02.1~dfsg-2
10.02.1~dfsg-3
10.03.0~dfsg-1
10.03.1~dfsg~git20240518-1
10.03.1~dfsg-1

Ecosystem specific

{
    "urgency": "unimportant"
}

Debian:12 / ghostscript

Package

Name
ghostscript
Purl
pkg:deb/debian/ghostscript?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected

Affected versions

10.*

10.0.0~dfsg-11
10.0.0~dfsg-11+deb12u1
10.0.0~dfsg-11+deb12u2
10.0.0~dfsg-11+deb12u3
10.0.0~dfsg-11+deb12u4
10.01.2~dfsg-1
10.02.0~dfsg-1
10.02.0~dfsg-2
10.02.1~dfsg-1
10.02.1~dfsg-2
10.02.1~dfsg-3
10.03.0~dfsg-1
10.03.1~dfsg~git20240518-1
10.03.1~dfsg-1

Ecosystem specific

{
    "urgency": "unimportant"
}

Debian:13 / ghostscript

Package

Name
ghostscript
Purl
pkg:deb/debian/ghostscript?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
10.03.0~dfsg-1

Affected versions

10.*

10.0.0~dfsg-11
10.01.2~dfsg-1
10.02.0~dfsg-1
10.02.0~dfsg-2
10.02.1~dfsg-1
10.02.1~dfsg-2
10.02.1~dfsg-3

Ecosystem specific

{
    "urgency": "unimportant"
}