CVE-2024-29904

Source
https://nvd.nist.gov/vuln/detail/CVE-2024-29904
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-29904.json
Aliases
Published
2024-03-29T16:15:08Z
Modified
2024-04-01T07:01:30.688867Z
Details

CodeIgniter is a PHP full-stack web framework A vulnerability was found in the Language class that allowed DoS attacks. This vulnerability can be exploited by an attacker to consume a large amount of memory on the server. Upgrade to v4.4.7 or later.

References

Affected packages

Git / github.com/codeigniter4/CodeIgniter4

Affected ranges

Type
GIT
Repo
https://github.com/codeigniter4/CodeIgniter4
Events
Introduced
0The exact introduced commit is unknown
Fixed

Affected versions

4.*

4.0.0
4.0.2

v4.*

v4.0.0-alpha.1
v4.0.0-alpha.2
v4.0.0-alpha.3
v4.0.0-alpha.4
v4.0.0-alpha.5
v4.0.0-beta.1
v4.0.0-beta.3
v4.0.0-beta.4
v4.0.0-rc.1
v4.0.0-rc.2
v4.0.0-rc.2.1
v4.0.0-rc.2b
v4.0.0-rc.3
v4.0.0-rc.4
v4.0.0.0-alpha.5
v4.0.1
v4.0.3
v4.0.4
v4.0.5
v4.1.0
v4.1.1
v4.1.2
v4.1.3
v4.1.4
v4.1.5
v4.1.6
v4.1.7
v4.1.8
v4.1.9
v4.2.0
v4.2.1
v4.2.10
v4.2.11
v4.2.12
v4.2.2
v4.2.3
v4.2.4
v4.2.5
v4.2.6
v4.2.7
v4.2.8
v4.2.9
v4.3.0
v4.3.1
v4.3.2
v4.3.3
v4.3.4
v4.3.5
v4.3.6
v4.3.7
v4.3.8
v4.4.0
v4.4.1
v4.4.2
v4.4.3
v4.4.4
v4.4.5
v4.4.6