CVE-2024-3104

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2024-3104
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-3104.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2024-3104
Published
2024-06-06T18:15:17Z
Modified
2024-06-07T14:56:05Z
Summary
[none]
Details

A remote code execution vulnerability exists in mintplex-labs/anything-llm due to improper handling of environment variables. Attackers can exploit this vulnerability by injecting arbitrary environment variables via the POST /api/system/update-env endpoint, which allows for the execution of arbitrary code on the host running anything-llm. The vulnerability is present in the latest version of anything-llm, with the latest commit identified as fde905aac1812b84066ff72e5f2f90b56d4c3a59. This issue has been fixed in version 1.0.0. Successful exploitation could lead to code execution on the host, enabling attackers to read and modify data accessible to the user running the service, potentially leading to a denial of service.

References

Affected packages

Git / github.com/mintplex-labs/anything-llm

Affected ranges

Type
GIT
Repo
https://github.com/mintplex-labs/anything-llm
Events
Introduced
0 Unknown introduced commit / All previous commits are affected
Fixed