CVE-2024-3150

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2024-3150
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-3150.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2024-3150
Published
2024-06-06T19:16:00Z
Modified
2024-06-07T20:13:21Z
Summary
[none]
Details

In mintplex-labs/anything-llm, a vulnerability exists in the thread update process that allows users with Default or Manager roles to escalate their privileges to Administrator. The issue arises from improper input validation when handling HTTP POST requests to the endpoint /workspace/:slug/thread/:threadSlug/update. Specifically, the application fails to validate or check user input before passing it to the workspace_thread Prisma model for execution. This oversight allows attackers to craft a Prisma relation query operation that manipulates the users model to change a user's role to admin. Successful exploitation grants attackers the highest level of user privileges, enabling them to see and perform all actions within the system.

References

Affected packages

Git / github.com/mintplex-labs/anything-llm

Affected ranges

Type
GIT
Repo
https://github.com/mintplex-labs/anything-llm
Events
Introduced
0 Unknown introduced commit / All previous commits are affected
Fixed