Improper Input Validation vulnerability in Apache Zeppelin.
The attackers can execute malicious queries by setting improper configuration properties to LDAP search filter. This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1.
Users are recommended to upgrade to version 0.11.1, which fixes the issue.
{
"cna_assigner": "apache",
"cwe_ids": [
"CWE-20"
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/31xxx/CVE-2024-31867.json"
}{
"extracted_events": [
{
"range": [
{
"introduced": "0.8.2"
},
{
"fixed": "0.11.1"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
},
{
"cpe": "cpe:2.3:a:apache:zeppelin:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0.8.2"
},
{
"fixed": "0.11.1"
}
],
"source": "CPE_RANGE"
}
]
}