CVE-2024-33531

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2024-33531
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-33531.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2024-33531
Published
2024-04-24T06:15:14Z
Modified
2024-07-08T18:27:16.253844Z
Summary
[none]
Details

cdbattags lua-resty-jwt 0.2.3 allows attackers to bypass all JWT-parsing signature checks by crafting a JWT with an enc header with the value A256GCM.

References

Affected packages

Git / github.com/cdbattags/lua-resty-jwt

Affected ranges

Type
GIT
Repo
https://github.com/cdbattags/lua-resty-jwt
Events
Introduced
0 Unknown introduced commit / All previous commits are affected
Fixed

Affected versions

v0.*

v0.1.1
v0.1.10
v0.1.11
v0.1.2
v0.1.4
v0.1.5
v0.1.6
v0.1.7
v0.1.8
v0.1.9
v0.2.0
v0.2.1
v0.2.2
v0.2.3