CVE-2024-35434

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2024-35434
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-35434.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2024-35434
Published
2024-05-29T19:15:48Z
Modified
2024-06-30T13:19:50.205355Z
Summary
[none]
Details

Irontec Sngrep v1.8.1 was discovered to contain a heap buffer overflow via the function rtpcheckpacket at /sngrep/src/rtp.c. This vulnerability allows attackers to cause a Denial of Service (DoS) via a crafted SIP packet.

References

Affected packages

Debian:11 / sngrep

Package

Name
sngrep
Purl
pkg:deb/debian/sngrep?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected

Affected versions

1.*

1.4.8-1
1.4.9-1
1.4.10-1
1.5.0-1
1.6.0-1~bpo11+1
1.6.0-1
1.7.0-1
1.7.0-2~bpo12+1
1.7.0-2
1.8.0-1
1.8.1-1

Ecosystem specific

{
    "urgency": "unimportant"
}

Debian:12 / sngrep

Package

Name
sngrep
Purl
pkg:deb/debian/sngrep?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected

Affected versions

1.*

1.6.0-1
1.7.0-1
1.7.0-2~bpo12+1
1.7.0-2
1.8.0-1
1.8.1-1

Ecosystem specific

{
    "urgency": "unimportant"
}

Debian:13 / sngrep

Package

Name
sngrep
Purl
pkg:deb/debian/sngrep?arch=source

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected

Affected versions

1.*

1.6.0-1
1.7.0-1
1.7.0-2~bpo12+1
1.7.0-2
1.8.0-1
1.8.1-1

Ecosystem specific

{
    "urgency": "unimportant"
}