CVE-2024-3568

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2024-3568
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-3568.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2024-3568
Aliases
Published
2024-04-10T17:15:58Z
Modified
2024-05-23T01:27:33.333322Z
Summary
[none]
Details

The huggingface/transformers library is vulnerable to arbitrary code execution through deserialization of untrusted data within the load_repo_checkpoint() function of the TFPreTrainedModel() class. Attackers can execute arbitrary code and commands by crafting a malicious serialized payload, exploiting the use of pickle.load() on data from potentially untrusted sources. This vulnerability allows for remote code execution (RCE) by deceiving victims into loading a seemingly harmless checkpoint during a normal training process, thereby enabling attackers to execute arbitrary code on the targeted machine.

References

Affected packages

Git / github.com/huggingface/transformers

Affected ranges

Type
GIT
Repo
https://github.com/huggingface/transformers
Events
Introduced
0 Unknown introduced commit / All previous commits are affected
Fixed

Affected versions

0.*

0.1.2
0.5.0

1.*

1.0
1.1.0
1.2.0

3.*

3.0.1

4.*

4.3.0.rc1

v0.*

v0.1.2
v0.2.0
v0.3.0
v0.4.0
v0.5.0
v0.5.1
v0.6.0
v0.6.1
v0.6.2

v1.*

v1.0.0

v2.*

v2.0.0
v2.1.0
v2.1.1
v2.10.0
v2.11.0
v2.2.0
v2.2.1
v2.2.2
v2.3.0
v2.4.0
v2.4.1
v2.5.0
v2.5.1
v2.6.0
v2.7.0
v2.8.0
v2.9.0
v2.9.1

v3.*

v3.0.0
v3.0.1
v3.0.2
v3.1.0
v3.2.0
v3.3.0
v3.3.1
v3.4.0
v3.5.0

v4.*

v4.0.0-rc-1
v4.1.0
v4.1.1
v4.10.0
v4.11.0
v4.12.0
v4.13.0
v4.14.0
v4.15.0
v4.16.0
v4.2.0
v4.3.0.rc1
v4.33.1
v4.4.0
v4.5.0
v4.6.0
v4.7.0
v4.8.0
v4.9.0