CVE-2024-3584

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2024-3584
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-3584.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2024-3584
Aliases
Published
2024-05-30T13:15:49Z
Modified
2024-06-02T22:56:56.911156Z
Summary
[none]
Details

qdrant/qdrant version 1.9.0-dev is vulnerable to path traversal due to improper input validation in the /collections/{name}/snapshots/upload endpoint. By manipulating the name parameter through URL encoding, an attacker can upload a file to an arbitrary location on the system, such as /root/poc.txt. This vulnerability allows for the writing and overwriting of arbitrary files on the server, potentially leading to a full takeover of the system. The issue is fixed in version 1.9.0.

References

Affected packages

Git / github.com/qdrant/qdrant

Affected ranges

Type
GIT
Repo
https://github.com/qdrant/qdrant
Events
Introduced
0 Unknown introduced commit / All previous commits are affected
Fixed

Affected versions

v0.*

v0.10.0
v0.10.1
v0.10.2
v0.10.3
v0.10.4
v0.10.5
v0.2.0
v0.2.1
v0.3.0
v0.3.1
v0.3.2
v0.3.4
v0.3.5
v0.3.6
v0.4.0
v0.4.1
v0.4.2
v0.5.0
v0.5.1
v0.6.0
v0.7.0
v0.8.0
v0.8.1
v0.8.2
v0.8.3
v0.8.4
v0.8.5
v0.8.6
v0.9.0
v0.9.1