CVE-2024-38537

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2024-38537
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-38537.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2024-38537
Aliases
Published
2024-07-02T20:15:05Z
Modified
2024-07-09T01:21:13.698262Z
Summary
[none]
Details

Fides is an open-source privacy engineering platform. fides.js, a client-side script used to interact with the consent management features of Fides, used the polyfill.io domain in a very limited edge case, when it detected a legacy browser such as IE11 that did not support the fetch standard. Therefore it was possible for users of legacy, pre-2017 browsers who navigate to a page serving fides.js to download and execute malicious scripts from the polyfill.io domain when the domain was compromised and serving malware. No exploitation of fides.js via polyfill.io has been identified as of time of publication.

The vulnerability has been patched in Fides version 2.39.1. Users are advised to upgrade to this version or later to secure their systems against this threat. On Thursday, June 27, 2024, Cloudflare and Namecheap intervened at a domain level to ensure polyfill.io and its subdomains could not resolve to the compromised service, rendering this vulnerability unexploitable. Prior to the domain level intervention, there were no server-side workarounds and the confidentiality, integrity, and availability impacts of this vulnerability were high. Clients could ensure they were not affected by using a modern browser that supported the fetch standard.

References

Affected packages

Git / github.com/ethyca/fides

Affected ranges

Type
GIT
Repo
https://github.com/ethyca/fides
Events
Introduced
0 Unknown introduced commit / All previous commits are affected
Fixed

Affected versions

0.*

0.9.0
0.9.1
0.9.2
0.9.3
0.9.4
0.9.5
0.9.6
0.9.7
0.9.8
0.9.8.1
0.9.8.2
0.9.8.3
0.9.8.4
0.9.9

1.*

1.0.0
1.1.0
1.1.1
1.2.0
1.3.0
1.3.1
1.4.0
1.4.1
1.4.2
1.5.0
1.5.1
1.5.2
1.5.3
1.6.0
1.7.0
1.8.0
1.8.1
1.8.2
1.8.3
1.8.4
1.8.5
1.9.0
1.9.1
1.9.2
1.9.9

2.*

2.0.0
2.0.0-beta.1
2.0.0-beta.2
2.0.0-beta.3
2.10.1b0
2.10.1b1
2.10.1b2
2.10.1b3
2.11.1b0
2.11.1b1
2.11.1b2
2.11.1b3
2.11.1b4
2.11.1b5
2.11.1b6
2.12.1b0
2.12.1b1
2.12.1b2
2.12.1b3
2.12.1b4
2.12.2b0
2.12.2b1
2.12.2b2
2.13.1b0
2.13.1b1
2.13.1b2
2.14.1b0
2.14.1b1
2.14.1b2
2.14.2b0
2.14.3b0
2.15.1b0
2.15.1b1
2.15.2b0
2.16.1b0
2.16.1b1
2.17.1b0
2.18.1b0
2.18.1b1
2.18.1b2
2.18.1b3
2.18.1b4
2.18.1b5
2.18.1b6
2.18.1b7
2.19.1b0
2.19.2b0
2.19.2b1
2.19.2b2
2.2.0
2.2.2
2.20.1b0
2.20.1b1
2.20.1b2
2.20.1b3
2.20.1b4
2.20.2b0
2.20.3b0
2.20.3b1
2.20.3b2
2.21.0rc0
2.21.1b0
2.21.1b1
2.21.1b2
2.21.1b3
2.22.1b0
2.22.1b1
2.22.1b2
2.22.1b3
2.22.2b0
2.22.2b1
2.22.2b2
2.22.2b3
2.23.1b0
2.23.2b0
2.23.3b0
2.23.3b1
2.23.3b2
2.23.3b3
2.24.1b0
2.24.1b1
2.24.2b0
2.24.2b1
2.25.1b0
2.25.1b1
2.25.1b2
2.25.1b3
2.25.1b4
2.26.1b0
2.26.1b1
2.27.1b0
2.27.1b1
2.28.1b0
2.28.1b1
2.29.1b0
2.29.1b1
2.3.0
2.30.1b0
2.30.2b0
2.30.2b1
2.31.1b0
2.31.1b2
2.32.1b0
2.32.1b1
2.32.1b2
2.33.1b0
2.33.2b0
2.34.1b0
2.34.2b0
2.34.2b1
2.34.2b2
2.34.2b3
2.35.2b0
2.35.2b1
2.36.1b0
2.36.2b0
2.36.2b1
2.36.2b2
2.36.2b3
2.36.2b4
2.36.2b5
2.37.1b0
2.37.1b1
2.37.1b2
2.37.1b3
2.37.1b4
2.38.1b0
2.38.1b1
2.38.2b0
2.38.2b1
2.38.2b2
2.38.2b3
2.39.1b0
2.5.0
2.5.1
2.6.0
2.6.1
2.7.0
2.7.1
2.8.0
2.8.1
2.9.0
2.9.0rc3
2.9.3a0
2.9.4

Other

fetch