CKEditor 5 is a JavaScript rich-text editor. Starting in version 40.0.0 and prior to version 43.1.1, a Cross-Site Scripting (XSS) vulnerability is present in the CKEditor 5 clipboard package. This vulnerability could be triggered by a specific user action, leading to unauthorized JavaScript code execution, if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration. This vulnerability only affects installations where the Block Toolbar plugin is enabled and either the General HTML Support (with a configuration that permits unsafe markup) or the HTML Embed plugin is also enabled. A fix for the problem is available in version 43.1.1. As a workaround, one may disable the block toolbar plugin.
{
"cna_assigner": "GitHub_M",
"cwe_ids": [
"CWE-79"
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/45xxx/CVE-2024-45613.json"
}{
"extracted_events": [
{
"range": [
{
"introduced": "40.0.0"
},
{
"fixed": "43.1.1"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"original_tag": "v43.1.1",
"range": [
{
"fixed": "6b1e550ba3eee4618f36258ee2ed7cbbc2361246"
}
],
"source": "REFERENCES_TAG"
},
{
"cpe": "cpe:2.3:a:ckeditor:ckeditor5:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "40.0.0"
},
{
"fixed": "43.1.1"
}
],
"source": "CPE_RANGE"
}
]
}