Coolify versions prior to v4.0.0-beta.420.7 are vulnerable to a remote code execution vulnerability in the project deployment workflow. The platform allows authenticated users, with low-level member privileges, to inject arbitrary shell commands via the Git Repository field during project creation. By submitting a crafted repository string containing command injection syntax, an attacker can execute arbitrary commands on the underlying host system, resulting in full server compromise.
{
"cna_assigner": "VulnCheck",
"cwe_ids": [
"CWE-20",
"CWE-78"
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/34xxx/CVE-2025-34161.json"
}{
"extracted_events": [
{
"cpe": "cpe:2.3:a:coollabs:coolify:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "4.0.0"
}
],
"source": "CPE_RANGE"
},
{
"original_tag": "v4.0.0-beta.420.7",
"range": [
{
"fixed": "4ea71ee0507f05da508de57536836e5865d1d410"
}
],
"source": "REFERENCES_TAG"
}
]
}