A stored Cross-Site Scripting (XSS) vulnerability exists in the administration panel of Flatpress CMS before 1.4 via the gallery captions component. An attacker with admin privileges can inject a malicious JavaScript payload into the system, which is then stored persistently.
{
"cna_assigner": "mitre",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/44xxx/CVE-2025-44108.json"
}{
"extracted_events": [
{
"cpe": "cpe:2.3:a:flatpress:flatpress:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.4"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "24a6feacf1747ec19725b52c097715c8ab9c4559"
}
],
"source": "REFERENCES_COMMIT"
},
{
"original_tag": "1.3.1",
"range": [
{
"fixed": "e3525112643d83f1d96b87f5d209bd9de8d78330"
}
],
"source": "REFERENCES_TAG"
},
{
"original_tag": "1.4.rc2",
"range": [
{
"fixed": "533d1c918a77fa2b57f561f9e0680b30c7dcf5b6"
}
],
"source": "REFERENCES_TAG"
}
]
}